FAKE IMAX B6AC 80W no menu and loop problem solutions

Recently bought on b6ac on ebay. did some lipo charging and discharge.

it did eventually had the auto discharge 1S then over voltage problem loop and all four buttons not responding. after i did the STOP/Enter button while powering. ( bad idea. dont do it! ).

found this page http://blog.lincomatic.com/?p=1725 and i did tried the solution there.

and failed to repair it with 6s battery  way.

then i decided to open it and i change the burnt resistor. and removed the irfz44n.

  1. i powered it and the discharge did finish without the over voltage error. NOW MENU Is back. all four button functioning. so i put back the irfz44n. upto today. b6ac is working. thou am not sure its calibrated  properly. anyways, as long as it works for now. All is ok 🙂

Hope this info help you guys that have the same problem.

Advertisements
This entry was posted in Electronics. Bookmark the permalink.

One Response to FAKE IMAX B6AC 80W no menu and loop problem solutions

  1. albertteng says:

    Althou the loop menu is fixed. Voltage is not calibrated properly. i had to do the 6s solution and all is ok for now.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s